分类
外匯交易策略

技术指标

11-28 6653

Highstock 自 6.0 开始内置提供 20 种常用的技术指标,使用它们非常方便,只需要额外的引入技术指标主文件( indicators/indicators.js ,也是 SMA指标文件)及技术指标对应的文件,例如添加 MACD 技术指标 指标需要引入的文件是

内置技术指标列表

截止到现在 Highstock 内置的技术指标有(共 20 种):

技术指标配置

技术指标相关的功能是以数据列的形式实现的,这也就意味着大部分 数据列配置 也可以在技术指标中使用,唯一需要注意的是技术指标数据列是以主数据列的数据进行计算的,所以无需给定数据配置,直接用 linkedTo 属性来与主数据进行关联,当主数据列的数据有更新时(例如进行 addPoint 操作),技术指标也会同步更新。

另外某些技术指标还有一些特有的配置,这些配置是写在 params 配置下,例如 params.period (周期)、 params.algorithm (算法)等。

同一个主数据列可以关联多个技术指标,下面的包含一个主数据列、2个 SMA 和一个 EMA 数据列的示例代码:

Y 轴绑定

部分技术指标(Bollinger Bands、EMA、Ichimoku Kinko Hyo、Pivot Points、Price Envelopes、PSAR、SMA、VbP、 VWAP、WMA、Zig Zag)可以直接和主数据列放置在同一个 Y 轴中,但某些技术指标(A/D、ATR、CCI、CMF、MACD、 MFI、Momentum、RoC、RSI、Stochastic)由于运算的结果和主数据列不是一个数量级,所以需要单独放置在另外一个 y 轴中,配置方法同 多轴配置 一样,步骤如下:

外汇技术指标

风险批露: 交易股票、外汇、商品、期货、债券、基金等金融工具或加密货币属高风险行为,这些风险包括损失您的部分或全部投资金额,所以交易并非适合所有投资者。加密货币价格极易波动,可能受金融、监管或政治事件等外部因素的影响。保证金交易会放大金融风险。
在决定交易任何金融工具或加密货币前,您应当充分了解与金融市场交易相关的风险和成本,并谨慎考虑您的投资目标、经验水平以及风险偏好,必要时应当寻求专业意见。
Fusion Media提醒您,本网站所含数据未必实时、准确。本网站的数据和价格未必由市场或交易所提供,而可能由做市商提供,所以价格可能并不准确且可能与实际市场价格行情存在差异。即该价格仅为指示性价格,反映行情走势,不宜为交易目的使用。对于您因交易行为或依赖本网站所含信息所导致的任何损失,Fusion Media及本网站所含数据的提供商不承担责任。
未经Fusion Media及/或数据提供商书面许可,禁止使用、存储、复制、展现、修改、传播或分发本网站所含数据。提供本网站所含数据的供应商及交易所保留其所有知识产权。
本网站的广告客户可能会根据您与广告或广告主的互动情况,向Fusion Media支付费用。 本协议的英文版本系主要版本。如英文版本与中文版本存在差异,以英文版本为准。

金融软件系统的技术指标

sandisks 于 2020-01-13 19:37:57 发布 865 收藏

07-22 2986

11-28 6653

12-26 226

系统技术指标 支持操作系统 测试设计部分:Windows7 SP1、Windows8.1、Windows10 1607及以上版本 测试执行部分:Windows7 SP1、Windows8.1、Windows10 1607及以上版本;Linux-RT;VxWorks 6.0。 实时性指标 ETest Studio同时支持非实时与实时系统仿真测试任务,可以形成ETest-USB、ETest-PCI、ETest-RT等架构模式。 ETest-USB、ETest-PCI设计器和执行.

04-15 137

系统技术指标 支持操作系统 测试设计部分:Windows7 SP1、Windows8.1、Windows10 1607及以上版本 测试执行部分:Windows7 SP1、Windows8.1、Windows10 1607及以上版本;Linux-RT;VxWorks 6.0。 实时性指标 ETest Studio同时支持非实时与实时系统仿真测试任务,可以形成ETest-USB、ETest-PCI、ETest-RT等架构模式。 ETest-USB、ETest-PCI设计器和执行.

01-06 1万+

这里写自定义目录标题欢迎使用Markdown编辑器新改变功能快捷键合理创建标题,有助于目录生成如何改变文本样式插入链接与图片如何插入一段漂亮代码片生成一个适合你列表创建一个表格设定内容居中、居左、居右SmartyPants创建一个自定义列表如何创建一个注脚注释也是必不可少KaTeX数学公式新甘特图功能,丰富你文章UML 图表FLowchart流程图导出与导入导出导入 欢迎使用Ma.

06-01 68

05-01 276

09-25 4万+

衡量一个软件系统性能常见指标有: 1.响应时间(Response time) 响应时间就是用户感受软件系统为其服务所耗费时间,对于网站系统来说,响应时间就是从点击了一个页面计时开始,到这个页面完全在浏览器里展现计时结束这一段时间间隔,看起来很简单,但其实在这段响应时间内,软件系统在幕后经过了一系列处理工作,贯穿了整个系统节点。根据“管辖区域”不同,响应时间可以细分为:

02-17 688

本章节重点介绍并回答如下几个问题: 1、容器云、微服务在云原生中所处位置? 2、云程平台在云原生架构中定位? 3、传统单体开发和云原生开发区别有哪些? 4、应用系统满足什么样要求才是云原生应用?有没有衡量指标? 一、什么是云原生 官方定义:云原生技术有利于各组织在公有云、私有云和混合云等新型动态环境中,构建和运行可弹性扩展应用。云原生代表技术包括容器、服务网格、微服务、不可变基础设施和声明式API。 官方定义重点描述是云原生底座,这些国内头部企业阿里、华为、腾讯均有对应产品,开源也有相关软件,

08-27 2万+

系统性能是一个系统提供给用户众多性能指标混合体。它既包括硬件性能,也包括软件性能。随着计算机技术不断发展,有关性 能描述也越来越细化,根据不同应用需要产生了各种各样性能指标,如整数运算性能、浮点运算性能、响应时间、网络带宽、稳定性、I/O 吞吐量、SPEC-Int、SPEC-Fp、TPC、Gibson mix 等。有了这些性能指标之后,如何来衡量这些性能指标呢?这就涉及了性能.

有哪些好用的通达信指标?

知乎用户 技术指标 ​

STICKLINE(ZSZG>ZSZD AND DUANFX=1, ZSZG, ZSZD, 10, 1),COLOR8E236B;

STICKLINE(ZSZG>ZSZD AND DUANFX=-1, ZSZG, 技术指标 ZSZD, 10, 1), COLOR007700;

DRAWLINE(ZSKS=1, ZSZZ, ZSJS=1, ZSZZ, 0), COLORFFFFFF;

STICKLINE(KX>0, KXG, KXD, 5, 1),COLOR007700,LINETHICK2;

STICKLINE(笔=1, KXG, KXD, 5, 1), colorgreen, LINETHICK2;

STICKLINE(笔=-1, KXG, 技术指标 KXD, 5, 1), colorred, LINETHICK2;

STICKLINE(段=1, KXG, KXD, 5, 0), COLOR007700, LINETHICK2;

STICKLINE(段=-1, KXG, KXD, 5, 0), COLOR0000CC, LINETHICK2;

DRAWTEXT(笔= 1, H*1.038, ''+H+''), COLORFFFFFF;

DRAWTEXT(笔=-1, L*0.96, ''+L+''), COLORFFFFFF;

VAR10:=IF(TROUGHBARS(3,16,1)=0 AND H>L+0.04,4,0);

DRAWTEXT(买1>0 OR 买2>0,L*0.985,'技术指标 买'),COLOR00FFFF;

DRAWTEXT(EN2 AND DTJZ10=1,L*0.93,'[类二买]'),COLORFFFFFF;

DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'[一买]'),COLORFF00FF;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.05,'[二卖]'),LINETHICK2,COLORFFFF00;

DRAWTEXT(EN2 AND PL20>REF(PL20,1) 技术指标 AND ZTJZ10=2,L*0.95,'[二买]'),LINETHICK2,COLORFFFF00;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.04,'[一卖]'),LINETHICK3,COLOR00FF00;

连线1:=BARSLAST(高点)>上1周期 OR BARSLAST(高点)>下1周期;

转强: STICKLINE(VAR8>REF(VAR8,1) AND VAR6VAR8,VAR8,0,2,0),COLORLIRED ;

持股: STICKLINE(VAR8>REF(VAR8,1) AND VAR8>0,VAR6,0,2,0),COLORRED;

观望: STICKLINE(VAR6REF(VAR8,1) AND VAR6>0,

VAR327:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND HIGH/CLOSE0, 技术指标 91, 0);

TJ1:=P1>T1 AND P2>T2 ;

TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));

局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);

局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);

局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);

局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);

低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)

判断:=IF(局部高点预选C=1 AND REF(距前低天,1)REF(小值周期,距前低天+1) AND 大值周期>REF(小值周期,技术指标 距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);

高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);

高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);

判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);

低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)

低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)技术指标 =4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-1),-1,0);

判断X:=IF(局部高点预选C=1 AND REF(距前低天A,1)REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);

高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(技术指标 HHV(H,距前低天A+1),1),1,0);

高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);

判断XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);

低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)

低保留XB:=IF(局部低点预选C=-1 AND REF(距前高天A,技术指标 1)=4 OR LLV(缺口判断,距前高天A)=-1 技术指标 OR 判断XA=-1),-1,0);

判断YX:=IF(局部高点预选C=1 AND REF(距前低天YA,1)REF(小值周期,距前低天YA+1) AND 技术指标 大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,技术指标 0);

高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);

高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);

判断YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)REF(大值周期,距前高天YA+1) AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);

低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)

低保留YXB:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)=4 OR LLV(缺口判断,距前高天YA)=-1 OR 判断YXA=-1),-1,0);

AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L